Users are unable to find claims in Billing Hub

Incident Report for Carbon Health

Resolved

This incident has been resolved. Please refresh your Billing Hub webpage.
Posted May 11, 2026 - 12:30 PDT

Monitoring

A fix has been released and we are seeing bills show again, though some may still be missing and filters specifically may still be broken

A full resolution should be out in ~2 hours

Please refresh BHT in the meantime to try and check for specific patients you need again
Posted May 11, 2026 - 09:46 PDT

Identified

The issue has been identified and a fix is being implemented. The fix should be released by 9am PST.
Posted May 11, 2026 - 08:38 PDT

Investigating

We are currently investigating this issue.
Posted May 11, 2026 - 07:15 PDT